TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Nov 24, 2017 8:47 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Jan 10, 2016 8:12 am 
Offline

Joined: Sat Jan 09, 2016 12:00 pm
Posts: 1
Location: Blackshear Ga.
My 2000 metro 1.3 runs great on the highway,but when you stop at a red light it idles so slow it almost shuts off.I also noticed running the heater fan slows it even more. I've installed new injectors, camshaft position sensor, map sensor,changed throttle body.I ran an OBD 1 scan.The manifold vacuum was a little low 15.I noticed on the metro forum which I made a password and username many times and the next time I tried log on it doesn't remember my password, I hope team swift is different.On the metro forum after I got on as a visitor there seemed to be others having the same problem with a 2000 metro. I did have a 95 1.3 metro that ran great and never had these problems but totaled it. Anybody had the same problem and solved it. Thanks Jim


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group