TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Mon Sep 25, 2017 2:19 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Aug 29, 2017 1:34 am 
Offline

Joined: Tue Aug 29, 2017 1:06 am
Posts: 3
Location: canada
hey to all fellow turbo sprint owners...had mine since brand new off showroom floor...30 years of fun..
still don't want to give up on it just yet..
quit firing while driving...
anyway no spark is the issue ...have two working coils so not the problem...seems there is no pulse on the neg side of coil when cranking...
never had an issue like this before ..any help would be appreciated ......


Top
 Profile  
 
PostPosted: Tue Aug 29, 2017 5:00 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11668
Location: columbus, ohio
there is a black electronics module positioned on the left strut tower. that's the ignition control unit.

it is most probably bad and in need of a new one. :wink:

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group