TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sun Jul 23, 2017 3:56 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Mon Oct 17, 2016 10:53 pm 
Offline

Joined: Mon Oct 17, 2016 10:36 pm
Posts: 2
Location: Ipswich
Hey just wondering if anyone could please give me some ideas on what possibly could be wrong.

Recently brought a 92 mh barina when buying the car the guy told me i needed to change the fuel pump , which thankfully i did as there was exposed wires, anyway after pump change an fuel filter change etc we proceeded to start her up , fuel in carby an good ole start your bast**d.. had her running but then she just decided to keep dying on me has half a tank of fuel in her so its not that haha once warm stays on but the revs are all over the place , an when i turned it off today she shuttered an delayed in turning off ,please any advice would help me an be greatly appreciated.
cheers sky . :D


Attachments:
File comment: engine bay from previous owners pics on here :)
4.jpg
4.jpg [ 312.1 KIB | Viewed 476 times ]
Top
 Profile  
 
PostPosted: Mon Oct 24, 2016 8:52 pm 
Offline

Joined: Fri Nov 18, 2011 10:58 pm
Posts: 75
Location: Brisbane, Australia
hi sky101, it sounds like you have a few problems,
first the carby is one of your problems, the 2nd, your timing is out,
I would recommend replacing the spark plugs if needed, and adj your
tappets, and replace the timing belt.
as for the running on problem, there is a fuel cut off switch in the carby,
witch should stop fuel flow to the motor, and there is probably carbon
build up in the combustion chamber that might be causing it to diesel on.

and welcome to the forum :)


Top
 Profile  
 
PostPosted: Thu Nov 03, 2016 3:34 am 
Offline

Joined: Mon Oct 17, 2016 10:36 pm
Posts: 2
Location: Ipswich
Thanks so much really appreciate it !

I recently got the carby rebuilt , because it was buggered from sitting for so long (this was done professionally)
I put it back on all lines connected properly took photos an have great memory but im unsure on how to do the a/f mixture he said he wound this screw in 3 turns . She started an idled after a few tweaks on the idol screw but now is revving too high an is this because I haven't adjusted the a/f ? An we did tinker with the timing an it says on bonnet 6 degrees BTDC an that were we put it back to . (Checked timing belt still all good)

Cheers sky


Top
 Profile  
 
PostPosted: Thu Nov 03, 2016 7:53 am 
Offline

Joined: Fri Nov 18, 2011 10:58 pm
Posts: 75
Location: Brisbane, Australia
hi Sky101,
I might be wrong, but when you redid the air lines, did you connect air line to the back bottom of the air cleaner?
the other thing is, when your carby was built did the builder recalibrate the auto chock? it might be going
to the third position on the high idle.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group