TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Sep 23, 2017 10:23 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Rear Defrost problems
PostPosted: Wed Jan 04, 2017 7:23 pm 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
I have searched for other posts but cannot find an answer.

- fuse is fine.

- fog lights work

- switch is not lit when the lights are on

- the positive power side of the feed to the back window reads 12V when the defrost switch is on.

- the rear defrost lines are all intact and there was a resistance reading with my ohm meter. I cannot recall the value but will check again.

- continuity from the window ground tab to the body is good. I even tried connecting a wire directly to the main chassis bypassing the hatch.

- I have taken the switch apart and cleaned the contacts and checked for continuity. The switch it works.

When I disconnect the ground from the window and press the defrost switch, the amber indicator lights up. But when I connect the ground to the window the switch does not light up.

I hope some of you have a solution to my rear defrost problem.

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
PostPosted: Wed Jan 04, 2017 7:49 pm 
Offline
User avatar

Joined: Tue Feb 04, 2003 2:36 am
Posts: 877
Location: Vancouver BC
Hi Clinton,

Here is a scan from the MK2 GTI manual. Wiring should be similar to MK3 even though the switch itself looks different.

Image

I think the defogger would work even if the [ON] indicator bulb in the switch is burned out. The other bulb in the switch is for nighttime illumination.

Quote:
When I disconnect the ground from the window and press the defrost switch, the amber indicator lights up. But when I connect the ground to the window the switch does not light up.


Your last observation that the switch lamp goes off when you connect the defogger wire ground suggests that while you have a ground connection, it is not a very good ground connection.

Cheers
Tom


Top
 Profile  
 
PostPosted: Wed Jan 04, 2017 8:04 pm 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
Thanks Tom,

I was referring to the same manual and mk 3 seem to have different wire colours.

The switch checks out fine. The on indicator light comes on when the ground is disconnected from the R/W but does not when the ground is connected. That is the weird part.

I hope the previous owner didn't hack up the wiring under the dash somehow.

At least I didn't junk the black car, yet.

It's so hard to give up on these swifts...

Cheers,
Clinton

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
PostPosted: Wed Jan 04, 2017 8:47 pm 
Offline
User avatar

Joined: Tue Feb 04, 2003 2:36 am
Posts: 877
Location: Vancouver BC
Quote:
The on indicator light comes on when the ground is disconnected from the R/W but does not when the ground is connected. That is the weird part.


Actually not weird at all. When multiple electrical components within a circuit use separate grounds that become corroded or loose, they will seek an alternate path to ground. This is why so many Swifts with bad wiring grounds or corroded lamp holders exhibit rear stop/tail lights that behave opposite to expectations, such as lighting up when they should stay dark, or dimming instead of staying lit.

Trace the defogger switch and defogger element wiring grounds, and clean each connection.. Good luck!


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 2:20 am 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
Well, I reseated three grounding points on the left side of the car. (And cleaned up the drivers door switch while I was at it.)

Measured the defrost element's resistance and it is 3.4 ohms.

Measured the total resistance through the element and hatch ground and it read 7.6 ohms. So I bypassed the hatch ground altogether to no avail.

I even disconnected the defrost and hooked up a light to the + & - leads and it lit up!

Reattach the leads to the defrost element and measured the voltage at the + lead and it read .35 volts.

Rechecked the previously rebuilt switch (it's a very simple toggle like knuckles wrote about) to make sure there is continuity when depressed between the red and yellow wires and it works.

Nope. Defroster and indicator lights still don't work when pressed.

I never like electronics during school. But the way I see it, the defrost side of the switch gets a single source of 12v from the red wire. When the circuit is closed it feeds the yellow wire and consequently the defrost, and the circuit board has a copper trace that goes to the Indicator light then its own ground at the nearby chassis. Which is the common ground or negative pole for everything. So why would the indicator light not come on and the voltage read less than 1 volt at the back?

Now. The only thing that is not working are the two little lights that come on when you turn the marker lights on. They are burnt out. Could that be the cause? Can't be since they are on a different circuit.

The last simple attempt is to swap the switch between the two cars and if that doesn't work then I have to chase the feed from the fuse to the socket to the switch.

At least While I was messing with all this, I took the cluster out cleaned it and remove the little green condoms off the lights. And replaced the burnt out light for the heater controls. Now I can see the gauges at night. There was some positive to end the night.

And my wife says, "you should just go buy a new car." She's thinking about the LC500 :roll:

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 3:20 am 
Offline
User avatar

Joined: Tue Feb 04, 2003 2:36 am
Posts: 877
Location: Vancouver BC
I'll search for my MK3 FSM tomorrow..

A non functioning Swift defogger switch lamp is a pretty extreme rationale for trading it in on a $100K Lexus. :shock:


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 11:31 am 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
Hard to understand women. They always say they don't care about cars...

I was happily driving my '96 civic si and then she saw a really fast white coupe pass then brake beside us one summer night, showing its bright red led brake lights and throaty exhaust. Next words out of her mouth was, "what car is that?" I could have driven the Honda for another 10 years minimum, hey I am not complaining about the '05 g35 6mt. 8) but it feels like a whale compared to the swift.

It's the time I'm not spending with her and our 5 month old that she is upset about. It's been a 6 year journey to become parents. I should bump my old intro post up.

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
PostPosted: Sun Jan 15, 2017 10:52 pm 
Offline
User avatar

Joined: Tue Feb 04, 2003 2:36 am
Posts: 877
Location: Vancouver BC
Congratulations on fatherhood. You know, kids can get imprinted as car guys and gals early, by helping their dad as early as 3 or 4 years of age. :lol:

Here are the relevant pages from the MK3 FSM. I think you may have a bad ground inside your hatch door. G400 reference. You need to remove the plastic cover in the hatch door to inspect the ground screw/bolt. The nighttime illumination bulb wiring is different from the defogger-on indicator bulb wiring. Both circuits are inside the defogger switch.

Defogger Wiring:
Image

Defogger Wire and connector/splice locations:
Image

Defogger Diagnosis:
Image


Top
 Profile  
 
PostPosted: Mon Jan 16, 2017 1:15 am 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
Is that wiring schematic in the 1994 FSM too? IE the fold out pages? I was only looking at page 8-30 for the defroster trouble shooting... That red/wht wire junctions out to the wiper which is odd.

I will check the wiring under the hatch cover again, next weekend. But I bypass the hatch by attached a wire from the element to another grounding point inside the chassis.

My son, Otis, is kind of like me when I was a kid. He likes to stare at me doing things more than being cuddled. This car obsession isn't something I would want him to have. It beats substance addiction, gambling and women I guess. He will have lots to play with. Maybe I should update my sig and list all the cars...

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
PostPosted: Sat Jan 21, 2017 11:58 am 
Offline

Joined: Sat Aug 28, 2010 3:19 pm
Posts: 187
Location: Vancouver, BC
While driving one afternoon during the week, the defrost decided to work for that trip. Along with the OEM clarion radio coming to life instead of the static crackle... for just that one day.

Judging by my renewed enthusiasm and obsession with this swift and hoarding more performance parts for it...

it might be my "Christine." :shock:

_________________
'93 swift GT white, '94 swift GT black
'10 SX4 AWD w/ CVT

'60 Austin Healey Sprite, '67 Austin Healey 3000, '74 celica GT w/ 18rg, '88 RX7 10th anniversary, '89 MR2 SC, '05 Infiniti G35 6MT

Had
'80 Renault Le Car, '73 Celica ST, '76 VW Rabbit, '96 Honda Civic Si coupe, '87 Toyota Corolla GTS hatchbk
Casually looking for
early 240Z, Celica All-Trac ST165, Supra Turbo A80, NSX


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Alexa [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group