TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Mon Sep 25, 2017 12:50 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri May 05, 2017 9:47 am 
Offline

Joined: Thu Mar 10, 2016 10:53 pm
Posts: 27
Location: San Diego, ca
Why does my 89 GTI idle fluctuates up and down between 2000 & 1000 RPM when I first start the car in the morning! It stops doing it after a few minutes? Why?


Top
 Profile  
 
PostPosted: Sat May 06, 2017 12:08 am 
Offline
User avatar

Joined: Tue Jul 01, 2008 9:46 pm
Posts: 801
Location: Great Falls ,Mt.
Mine was doing that only it was going up to 3000 rpms. It's a sign of a bad cold start valve which is on the back of the intake plenum. I took the valve off and made a new gasket without the hole in it and bolted it back on and it works great now.


Ken............


Top
 Profile  
 
PostPosted: Sat May 06, 2017 6:47 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11668
Location: columbus, ohio
yep, it's a bad cold start valve. :blackeye:

they used a wax bead in its design that degrades after time. then the valve won't remain open to control idle.

i replaced mine with a blanking plate. now when i start the engine it goes directly to it's base idle of 800 rpm and stays there. :wink:

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Sun Jun 25, 2017 10:29 am 
Offline

Joined: Mon Jun 05, 2017 10:31 am
Posts: 3
Location: Pakistan
Hi ,
I might not be posting to the exact/correct forum , but couldnt find the exact one . However, I have swapped g13dohc/g16 , running g10 ECU and throttle . Now the problem is that the car is not showing up similar potential as my previous setup , that was g13dohc/g16 with g16 ecu and throttle. I am running it on 95 Ron on 3-4 bar fuel pressure. Maybe it's because of the ECU? And I am running d16 injectors.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group