TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Oct 17, 2017 1:03 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Dec 17, 2014 6:04 pm 
Offline

Joined: Sat Oct 15, 2011 5:03 am
Posts: 204
Location: lake stevens, wa
So we just put a 1.6 in and used 1.6 injectors etc. Runs good driving around town. But if you are part throttle and Rev it over 4k it starts to surge like running out of fuel. However, at wot runs fine. A few things to note are it has a mild 3tech cam. It is turbocharged, but symptoms happen out boost and in boost depending on throttle angle. I tried a 2 bar map and 260 injectors to see if it was fuel and or boost related. But still does same thing. I'm wondering if it's an o2 sensor or something. I'll post a video.

In the video right before I do wot in 2nd it does the surge thing in 1st.

[youtube]G16t suzuki swift test run 3: http://youtu.be/unmlL5t3Uc4[/youtube]

_________________
GEO MAFIA!
00 swift 2dr turbo 1.3 5spd 4.10. Sold to friend.
93 geo metro with 96 1.3 5spd swap turboed at 5psi. roommates.
14 ford Mustang v6.


Top
 Profile  
 
PostPosted: Wed Dec 17, 2014 11:45 pm 
Offline
User avatar

Joined: Tue Jul 03, 2012 12:19 pm
Posts: 344
Location: vancouver island, canada
First thing I woukd check is fuel pressure. Had the same thing happen. Had to remove hood and install pressure gauge and drive it. Every time it did that the pressure was droping like a rock.

_________________
92 geo metro 1.0L 5 spd. 2 dr Soon to be my turbo swap car. (Dragonfly) sold
91 pontiac firefly, 1.0L 2dr auto. stock. (The crap can) sold
91 chevy sprint. 1.0L 5 spd. My first turbo swap. (Red rocket) now the purple nurple
95 geo metro. 1.3L auto parts car. (Scrap)
91 chevy sprint turbo, blueboy keeping it "stock"


Top
 Profile  
 
PostPosted: Thu Jun 18, 2015 6:40 am 
Offline

Joined: Tue Oct 03, 2006 10:43 pm
Posts: 720
Location: Texas 75150
I had the same problem until I replaced the cam sensor. My engine would not rev past 3,500 rpm.
Also a dead front 02 sensor. The 02 sensor showed no resistance with a volt/ohm meter.
The cam sensor fixed the rev limit issue, the 02 sensor fixed the surging issue.

_________________
Fainya
97 Geo Metro LSI,1.3L-GT-DOHC-16v,4.10 5-speed,A/C,170,000,suspension lowered 1",4 wheel disk brakes,15"alloy wheels with 185/50-15 Toyo's,GT bucket seats,analog oil pressure gauge,cruise control, new paint job. 40 mpg at 65 mph.
Good, fast, cheap. You only get two.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group