TeamSwift
http://teamswift.net/

Swift GA Turbo (GAT) -- HUGE picturess
http://teamswift.net/viewtopic.php?f=32&t=61831
Page 1 of 1

Author:  CMA [ Mon Jul 25, 2016 9:44 pm ]
Post subject:  Swift GA Turbo (GAT) -- HUGE picturess

This is my very first car that my brother gift in 2003 (when I was 18 years old at that time.) It was very high km as over 300k km. I don't remember and I suck at take some pictures so I will do my best to explain.

Image
Image
Image
Image
Image
Image
Image

Basically It was based metro... everything was cleaned and lightly mods such as air filter and Ragtop's vert cluster that we traded over the shipment. :lol:


I also remember it was very dangerous to drive... probably due to worn strut and spring and weak metro brakes (solid rotor.)

Author:  CMA [ Mon Jul 25, 2016 9:56 pm ]
Post subject:  Re: Swift GA Turbo (GAT)

My brother borrowed my car and blew the engine because of the nut from the air filter was loosen and fell into the engine. Oh well.

Image

Found the donor for 1200cdn! I remember it was knuckles's ex T3 with repaired floor pan.

Too bad, I can't find the picture of removed the metro engine and install the T3 engine into my Swift GA... then swapped the front suspension and brake system, and then swap the fuel pump. Only it stopped me to start the car is I can't rewire the harness to accept ignition and I gave up then storaged for 2 month until I asked Lithan to do wire stuff...

Image
Image
Image
Image
Image
Image
Image
Image
Image
Image

Now T3 is using the front suspension and brake from metro :lol: Then instantly sold it for 300CDN. =)

Author:  CMA [ Mon Jul 25, 2016 10:29 pm ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

After returned from Lithan's 9 months to re-wire, repair the rust at driver side, welding the exhausting pipes, and add the missing lower radiator supporter. I was so excited to drive but not satisfied so I ordered, bought and installed some parts into my GAT.

Engine
- Unknown blue VAF box with K&N filter
- Lightweight battery that pounds 10 lbs.
- 8mm Auroa ignition wiring

Suspension
- Turbine Tech lower brace
- Murr front upper and lower strut bars
- Murr's mid harness bar
- Murr's rear upper strut bar.
- Ltlsu spring with sliver KYB

Wheel
- 185/60R14 tires from Daewoo Aevo
- 14"x6" with 4x114.3 customize rims from unknown Honda... Probably Accord.

Huge handling changed!

Brake
- Untouched Turbo3 brakes
- New brake fluid DOT3 :lol:

Interior
- GTi steering wheel
- Only front 2 seats (I still have rear seats and it's for sale)

Exterior
- Factory Swift GTi Body kits... only one bad paint job was white... Too lazy to re-paint.
- Metro mirror... I don't like how GTi mirror looks.

Image
Image
Image
Image
Image
Image
Image
Image

Author:  CMA [ Mon Jul 25, 2016 11:12 pm ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

This post is probably saddest story I ever told.

After drove GAT for 10 years (?) 1st synchro was worn and pop out but I still can drive with 2nd gear until finally the clutch started to slip. I storage my GAT at outside of friend's shop so I can rebuild tranny at BCIT (while I was student)... Really bad ideas.

Why bad ideas?
- I fried the ECU or maybe whole wiring harness as I jumped the wrong terminal of the battery... it was too dark to see.. I was so an idiot.
- The area was full of garbage people... thieves and terrible stories. The wheel stolen, wipers and some damage done to body and window. :?
- Just rebuilt tranny after 6 months of storage... installed it too.
- Try to diagnosis the car with my poor electric diagnosis skill as I was not completing the electronic course at BCIT.
- At same time, I still not able to solve the issues so I thought engine might be toasted... I was also an idiot... but I want to rebuild the engine so I can start over tho. :? Lesson learnt.

- Remove the engine then dissemble to get stuff ready to be cleaning, paint and rebuild
- After talk to Supef1y to rebuild the head and then try to ship it to him.
- for more than 8 months... the head never arrived there... Struggle with Canada post then finally gave up.
- Gave up and storage it at my friend's friend's farm for 1.5 years... Really bad idea... Damn rats poops in my car and sun damage the paint.

- My friend moved out from his shop and lost my engine block. I was depressed about it... same for my head...
- Luckily He found the 180k T3 engine that sat in his shop for more than 10 years. It was free...

Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image
Image

Fuckers
:x :x :x


Image
Image
Image
Image
Image
Image

Lesson learnt.
:| :| :| :|

Author:  CMA [ Mon Jul 25, 2016 11:42 pm ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Inspected the free Turbo3 engine and I found the yellow marks... it was not very clear but I can guess what it said.

Run very strong but smokes. That's it as what I can know from this Turbo3 engine.

It has has some missing parts but lucky i have a ton of parts. Only one thing I can't find is my Turbo3 coolant turbo. I was in hurry to get two tubes from metro and attempted to weld the bango pipe onto the tube. It was failed after testing with the soap and air method. I decided to cut the pipe from failed one then added into to the coolant tube.


Image

Not able to decrypt other words...




Image
Image
Image

Turbo3 coolant tube is extremely rare to find. Funny part is, my friend found one for me in about 5 weeks later so I kept it as my back up!


Note: Just realize after look at the picture that I left and extra clamp there... I will re-check if I need to remove or leave it... :mrgreen:

Author:  CMA [ Mon Jul 25, 2016 11:45 pm ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Alright I will post more later... :blackeye:

Author:  suzukitom [ Tue Jul 26, 2016 12:37 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Very interesting history! It is good that you decided to keep your first car. Very few people would have the patience to keep and repair the car after all it has been through.

:thumb2:

Author:  944door [ Tue Jul 26, 2016 9:45 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

I still have my 4 door metro it was my first car had it since 2002

Author:  CMA [ Thu Jul 28, 2016 12:41 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Great.. Is it still in good condition? Nothing is showing any bad signs?

By the way... Just re-check the coolant T pipe mod... I should remove the clamp... Oops... I will fix it later... Lucky it was not leaking or something.

Author:  CMA [ Thu Jul 28, 2016 1:04 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Sorry I didn't take any pictures where I assembled some parts then transaxle then putted into the dirty car. Too disgust to show. so dirty. :lol:

Anyway after installed the engine and transaxle into the car then I was about to add oil filter and fluid. Thanks god I had sharp eyes and found the hole behind the oil return bango. I was like NOOOOOO why! I guess my friend pulled the engine out of the car in the wrong way and damage the return line pipe.

I did remove the bango in the wrong method... and damage the thread on the engine. :| I spent a lot of times to research what thread I need to use... Finally I found out it was 1/8 NTP 27 but I also confirmed it as I tested it on the dummy block. I only have one chance to not screw up the engine block.

After tapped the engine block without panic. and it was fitting prefect. Then I attempted to connect the oil returned pipe from my other turbo but I was so struggled to install it because of tight room and turbo design. I really wish I could take engine out of the car and disassemble again but I can't.. So stubborn I was.

Gave up with that oil returned pipe and I find another one from 2nd turbo one which was in very good condition. After installed the oil return pipe smoothly and I realize my other one was mis-shape therefore hard to install.


I successfully add the oil fluid and no sign of leaking... whew.


The new problem is no starts but cranks. That damn curse I had same problem a long time ago. :evil:

Image
Image
Image

Author:  CAMI Man [ Thu Jul 28, 2016 11:15 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Glad you are making progress . :D
Any idea of the problem with no start ??

Author:  CMA [ Wed Sep 13, 2017 1:02 am ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Sorry not update for a long time... I simply forget about this thread and have to deal some issues in my real life.

Anyway. After towing the GAT from my work to the street nearby my home and attempt to diagnosis. I decided to re-start over my process.. First thing I checked the fuel pressure and find out that it had no pressure. :huh:

Image

Time to check the fuel line... I used my spare fuel rail and test the pressure... still zero.

Image

I was like huh... then test my old FP and have good pressure. (I was very cautious with fuel and battery tho)

Suspected something is wrong with the FP... (as I knew that fuel gauge worked properly)

Image

Author:  CMA [ Wed Sep 13, 2017 12:39 pm ]
Post subject:  Re: Swift GA Turbo (GAT) -- HUGE picturess

Next day, I took my time to remove the gas tank and then took a look at FP... It seems okay to me.

Image

The gas tank was very dirty and inside was a little rust. Can't complain.

Image

Left is DSM and right is T3.

Image

Installed original T3 FP into the tank and take a test...

Image

Image


Stil low pressure... but almost zero pressure... so It was not solving the problem. :huh:


Tell me what's wrong? :lol:

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/