TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Jul 23, 2014 5:37 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 105 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next
Author Message
 Post subject: Re: My hybrid build
PostPosted: Sat Jun 02, 2012 5:35 pm 
Offline

Joined: Fri Feb 13, 2009 7:10 pm
Posts: 852
Location: Vancouver, WA
thanks. ill be starting the build on mine soon

_________________
98 swift 1.6 16v swap
03 cobra bolt ons
97 3000gt vr4 e85, high comp, bolt ons
too many others to list


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Aug 15, 2012 6:31 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
I had some problems with the computer and found out the daughter board was going bad. Also i changed the magnetic pickup to a halleffect sensor which also made a huge difference. so tuning today. not sure yet if im doing e85 or not.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Aug 15, 2012 10:56 pm 
Offline

Joined: Mon Jun 20, 2011 7:45 pm
Posts: 135
Location: Norcross, GA
:thumbsup: still watching


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Mon Aug 20, 2012 10:09 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
225whp 230ftlb at i think it was 8000rpm @ 13.5psi. I think its the bearing on the input shaft that has been giving me a problem and making noise. But basically what we are seeing is at idle in neutral it sounds like throughout bearing noise but it will idle a little funny. In gear clutch out same thing but the noise goes away with alittle throttle. Also the noise will just randomly go away and when it does it feels like it drops 1-2 cyl but checked and they are still working. Now you push the clutch in and it idles normal. So im going to look for another jy trans and swap them out and if all goes will have it running again in like 2 weeks. Then i will go from the 13psi to 18-24psi for pump gas and check the number + lower the limiter to about 7200-7500rpm adjust the cam gears and hook up the antilag. Let me know what you think about the numbers and lets just say with the pull this thing has doing one pull on the street it dont spin much till the top of the gears. Im talking 5500-6000rpm and it just barely starts to spin even though by 4000rpm im in boost. This turbo actually is working out very very well. Lag=traction and very nice curve. it is straight up as of now from like 3500rpm till rev limit. thanks stephen


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Aug 23, 2012 9:54 pm 
Offline
User avatar

Joined: Fri Jan 08, 2010 9:56 pm
Posts: 408
Location: colorado river, arizona USA
Any updates worth mentioning..i like your combo..id like to hear more..trans sorted out?


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Aug 23, 2012 11:03 pm 
Offline

Joined: Mon Jun 20, 2011 7:45 pm
Posts: 135
Location: Norcross, GA
good to know the turbo choice is working out.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 12, 2012 6:32 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
My new squirt came in. I got a MS3X. So once i get it hooked up and tuned ill let you know. Im going to try hooking up the ebc and table switching so i can have a 15psi tune and run it the first 2 gears and if i need more the the like 235-240whp ill flip the switch and swap to 24psi. Ill let you know when its done.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Tue Sep 18, 2012 11:26 pm 
Offline

Joined: Tue Dec 23, 2008 3:44 am
Posts: 435
Location: castlerock Wa,
what year is your trans out of? i see yours has a round puck attached to the gear selector, and mine does not. do u see any reason for it?

also what rpm are you turning at 70mph?

I also think i have a bad input shaft bearing, it makes a horrible sound between the motor pulling and bein slowed down by the wheels. have you investigated the issue yet?

By the way im really pleases with the trans minus the bad bearing, i have dumped the clutch (unsprung 4puck) many times, burnouts, 5th down to 2nd to redline. it just flat takes it. i have a video in my trans swap thread of one of the shorter burnouts.

_________________
If you ain't First your last - Ricky Bobby

1990 swift GL Twincam swap
Hyundai trans swap- in progress


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 19, 2012 10:55 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
I just got it running again i swapped it to a ms3x because my ms2 died. The rpm at 70mph im not sure aout because i havent hooked the speedo up yet. What cable did you use to hook yours up??? And this trans is an 01 accent. If i am hearing right we can use a dsm lsd in this trans even though it turns the opposite direction. No i havent investigated it i know the bad trans looked brand new inside no staining from oil or anything so im guessing thats why it was in the junkyard from a bad trans rebuild. I havent test the trans with any slicks but it takes everything else no problem it seems. And i know a fewe of these launches would have killed a swift one the first time i tried or even some of the roll races at the power im at now.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 19, 2012 8:49 pm 
Offline

Joined: Tue Dec 23, 2008 3:44 am
Posts: 435
Location: castlerock Wa,
I am using the gti cable, i just cut the gt housing and cut the Hyundai housing to the right length and used a little pipe to aline the housing and taped it for now. the gt cable on the trans side fits in the Hyundai trans just the same as the gt trans.

i haven't been able to find much on the web about these transmissions, is there a site you have come a crossed that is any good? i want to know if the bell housing is different between the 96-99 and the 00-06. the parts listing show them as different?

_________________
If you ain't First your last - Ricky Bobby

1990 swift GL Twincam swap
Hyundai trans swap- in progress


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 19, 2012 9:04 pm 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
the bell housings should all be the same. I got a eclipse cable that i may try putting in tommorrow to see if it will work. i think it will. Im at about 3200-3300 at 70mph on the gps. I am having problems with my ms3 with the crank sensor not reading strong enough so im losing sync at 6500rpm and on 13psi i still made 188whp at that rpm if i get that fixed i will try to strap it back down on the rollers.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 19, 2012 9:11 pm 
Offline

Joined: Tue Dec 23, 2008 3:44 am
Posts: 435
Location: castlerock Wa,
Let me know if the eclipse cable works then i can get rid of the jimmy rigged cable i have.

_________________
If you ain't First your last - Ricky Bobby

1990 swift GL Twincam swap
Hyundai trans swap- in progress


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Sep 20, 2012 2:25 pm 
Offline

Joined: Fri Feb 13, 2009 7:10 pm
Posts: 852
Location: Vancouver, WA
the shift actuator assy changed for 00 so the shifter cables are different too.

im pretty sure this is why the part number would have changed

_________________
98 swift 1.6 16v swap
03 cobra bolt ons
97 3000gt vr4 e85, high comp, bolt ons
too many others to list


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Fri Sep 21, 2012 11:19 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
Ok im still having crank sensor issues but i did take it to the track last night only turning 5500rpm. I wont say the times because they were pathetic because of the problems. But i did try out the antilag and was launching at 4000rpm on 5psi and the trans didnt seem to have a problem with it. Wil keep you posted. On another note if any of you guys know anyone wanting to sell one of striders intakes preferably in red let me know mine keeps cracking so i idle at like 1200rpm and am tired of this damn intake.......


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 26, 2012 6:39 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
OK got some more news. I got the speedo hooked up eclipse cable works fine just a little long. Got the tach hooked up and working. Still dont have the crank sensor tuned in. But after some hard launches i did break a stud off of my adapter plate. :( will post updates as they come


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 26, 2012 7:46 pm 
Offline

Joined: Tue Dec 23, 2008 3:44 am
Posts: 435
Location: castlerock Wa,
i had the same problem with my plate, but mine was when i was torquing it down. i ended up drilling half the thickness of the plate with a bigger drill bit then welding the studs flush with the plate.

_________________
If you ain't First your last - Ricky Bobby

1990 swift GL Twincam swap
Hyundai trans swap- in progress


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Sep 26, 2012 10:13 pm 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
Mine we thread the plate screwed the stud in them welded the back of them. So I'll hit the track with some timing tomorrow and see if that crank sensor will let me do a good pass


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Oct 04, 2012 6:56 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
Im still trying to get everything going right. I unhooked my fan and it cleared up alot but it does still hickup everyonce in awhile. So i really need to find someone who knows how to adjust these filters. I will order a new fan once i sell my gta or my 414sbc. There are some things i need to take care of like my adapter plate needs to be remade with dowels. And the trans pops out of 4th gear now. So from what i understand a dsm/ecdlipse/talon lsd bolts into the accent trans. I need a lsd bad. I can spin 1-4th gear if i try when it dont hickup on my 205/50/15 nitto neo gens. Track again tonight last week sucked i would get maybe a half a pull befor it would act up. I did do some good hard launches3800rpm and 5psi off the antilag. only 2.4- 2.8 60ft because i need some slicks. So i will try again tonight.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Mon Oct 15, 2012 6:49 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
Track again this pat thursday. car ran great on the way to the track. I charged the battery all day befor the track. I got two solid runs in on street tires and ran a 10.2 at 78mph launching off the antilag and spun pretty much all track and the second run babied it and launched from about 2000rpm still spun when hitting boost and ran a 9.8 at 81mph with a 2.8 60ft. Then it started acting up after that run and found that my altenator decided to die. So ill get another altenator and see how long the trans last. This adapter plate sucks that was made. I have a friend that is going to make me a new one that i know will be right. Then its time for me to find a new trans and maybe an lsd.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Oct 17, 2012 8:08 am 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
I am getting so tired of all the little problems with this car....... This trans is pretty much dead. No 4th and if you try to shift quickly or even mildly quick the trans goes right past 2nd and you have to clutch in and pull it out of gear and put it back in. It feels like the input shaft bearong is dead again. So im just going to park the car until i get a new adapter plate made and a new intake manifold. I had the car out last night and went with a few guys to race or even watch but the trans wasnt having it. So i will be looking for a new intake and im not sure what i want to do. I want one of striders and he said he would make one for me but on the other hand i could do a stock intake and probably only lose a few hp and tq....... there would be like a $400 difference which would you guys think. I only plan to turn the motor to where it peaks on power and using the adj timing gears im going to try to get itdown between 7000 and 7500rpm. As of now it still rises straight up at 8k till it hits the limiter.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Oct 18, 2012 12:09 pm 
Offline
User avatar

Joined: Tue Mar 08, 2005 12:59 am
Posts: 1024
Location: Canby, OR
How did you both center the bell housing pattern(s) on the crankshaft/trans input shaft centerlines? I'm betting that is why you are both going through bearings. Measurements should have been taken with calipers at a minumum- and the adapter plate either should have been laser cut or machined on a mill with a DRO. Hand layout can not be accurate enough for how closely toleranced this needs to be.

_________________
Anyone who's been around children will tell you that they are in fact quite stupid. Many of them cannot even read.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Oct 18, 2012 8:42 pm 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
A pilot alignment tool was made to center from the swift crank on to the trans spline and then a template was made but i agree that its off. thats why i need to have another one made.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Tue Jul 16, 2013 10:18 pm 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
Ok back at it again. I'm pulling motor and trans tomorow so one of my friends can make me a better adapter plate that don't get ripped apart. Last time had no dowels. This time it will have dowels and 360radius for the plate.


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Wed Jul 17, 2013 10:07 pm 
Offline

Joined: Mon Jun 20, 2011 7:45 pm
Posts: 135
Location: Norcross, GA
nice to hear an update. :yeahyeah


Top
 Profile  
 
 Post subject: Re: My hybrid build
PostPosted: Thu Jul 18, 2013 8:52 pm 
Offline

Joined: Mon Nov 12, 2007 1:00 am
Posts: 660
Location: Lakeland , Florida
I might acrually go a different route snd sell my 500 dollar custom axels and the broken adapter plate to who every want to try to make it work. I may just be putting a sidekick 5spd in with a ford 8.8 rear. I should know more next week. If you are interested in the swap stuff shoot me a message and offer. Thanks stephen


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 105 posts ]  Go to page Previous  1, 2, 3, 4, 5  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group